Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: So my mag 24.....

  1. #1
    Guest
    Join Date
    Oct 2010
    Location
    Grapeville PA
    Posts
    255

    So my mag 24.....

    Is ungodly loud. Dunno how long I will put up with this. Any suggestions on a submersible pump that pushes about the same gph?

    Sent from my DROIDX using Tapatalk

  2. #2
    Guest
    Join Date
    Dec 2010
    Location
    Armstrong County
    Posts
    125
    Quiet One 9000

  3. #3
    Guest
    Join Date
    Oct 2010
    Location
    Grapeville PA
    Posts
    255
    I've heard from ppl that their name is an oxymoron lol. Not very quiet but rather on the loud side

    Sent from my DROIDX using Tapatalk

  4. #4
    Guest
    Join Date
    Dec 2010
    Location
    Armstrong County
    Posts
    125
    I'm running a 6000 (return) and 2200 (chiller) in my 90's fuge and a 4000 (return) and 2200 (chiller) in my 40's fuge and I'll swear by them. BTW, both returns are throttled a little too ............
    Last edited by big dog; 05-10-2011 at 12:12 AM.

  5. #5
    Guest
    Join Date
    Oct 2010
    Location
    Grapeville PA
    Posts
    255
    Yea currently I am running a mag 9.5 and a mag 5 and both are dead silent. Which is why I am kind of baffled about how loud this 24 is. My brother runs a 12 and its pretty darn quiet as well.

    Sent from my DROIDX using Tapatalk

  6. #6
    Guest
    Join Date
    Dec 2010
    Location
    Armstrong County
    Posts
    125
    Is it setting on the sump bottom? You might try putting it on a piece of eggcrate, that may help. Do you know where the sound is coming from etal ...... vibration, water flow, internal motor noise????????????

  7. #7
    PMASI Board Member
    Join Date
    Dec 2010
    Location
    Freedom
    Posts
    445
    I replaced all my single pumps with maxijet utility pumps, the 4500 and 3000. On my 210 i run two 3000's and you wouldn't know they are there.

    They also have the cheesy flow adjustment on the front

  8. #8
    Guest
    Join Date
    Oct 2010
    Location
    Grapeville PA
    Posts
    255
    Its on a piece of rubber pond liner I folded up to make a cushion. I am going to try and replace the impeller to see how that works. It sounds like it us coming from there

    Sent from my DROIDX using Tapatalk

  9. #9
    George,

    Replacement impellers frequently fix this. I may even have one for a MAG 12 laying around. I'll try to find it and let you know.

    Adam

  10. #10
    Guest
    Join Date
    Oct 2010
    Location
    Grapeville PA
    Posts
    255
    Thanks adam, I replaced the impeller and it did help. But it is still rather loud for my taste. Gonna try a different pump and just use this one for wc's

    Sent from my DROIDX using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •