Results 1 to 3 of 3

Thread: John Guest Quick Connector Fittings for 1/4 Pipe RO Water

  1. #1
    PMASI Member
    Join Date
    Oct 2010
    Location
    Irwin, Pa
    Posts
    124

    John Guest Quick Connector Fittings for 1/4 Pipe RO Water

    I was standing next to my 30 gal RO holding tank and my 1/4" line pop off, spilling water lucky I was standing there. Could have been a mess I leave it running all night long using a float valve to turn it off. Has anybody had this happen and now I'm gun shy.
    Any suggestions???
    [EMAIL="gswiech@gmail.com"]gswiech@gmail.com[/EMAIL]

  2. #2
    Guest
    Join Date
    Oct 2010
    Location
    Grapeville PA
    Posts
    255
    Quote Originally Posted by high-mark View Post
    I was standing next to my 30 gal RO holding tank and my 1/4" line pop off, spilling water lucky I was standing there. Could have been a mess I leave it running all night long using a float valve to turn it off. Has anybody had this happen and now I'm gun shy.
    Any suggestions???
    I would cut the line and make sure it's a clean cut and push it back in. If it pips out again I would replace the fitting. I've heard of this happening, but it's not very common.

    Sent from my VS980 4G using Tapatalk

  3. #3
    PMASI Member
    Join Date
    Oct 2010
    Location
    Irwin, Pa
    Posts
    124
    Will try both, thanks
    [EMAIL="gswiech@gmail.com"]gswiech@gmail.com[/EMAIL]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •